Batch Print Latency

Incident Report for Net Health StatusPage

Resolved

Our team has addressed the recent issue that was affecting some users' ability to complete Batch Print requests. The functionality is now performing as expected.

We have not received any additional reports at this time. If you are still experiencing any issues, please reach out to Support so we can assist you directly.

We appreciate your patience and understanding as we worked through this.

— The Net Health Team
Posted May 23, 2025 - 07:54 EDT

Update

We are continuing to investigate this issue.
Our technical team is still actively working to identify the root cause of the latency affecting Batch Print requests. We understand how important this functionality is to your daily workflow and will share additional updates as soon as more information is available.

Thank you for your continued patience and understanding.
– The Net Health Team
Posted May 22, 2025 - 09:55 EDT

Update

We are continuing to investigate this issue.
Posted May 21, 2025 - 10:13 EDT

Investigating

We are currently investigating an issue affecting some users where Batch Print requests may become stuck in a loading state and fail to complete as expected. Our technical team is actively working to identify the root cause and implement a resolution.

We understand how critical this functionality is to your workflow and sincerely apologize for any disruption this may be causing.

Thank you for your continued patience and understanding.
– The Net Health Team
Posted May 20, 2025 - 16:46 EDT
This incident affected: WoundExpert.