Latency in Billing Module
Incident Report for Net Health StatusPage
Monitoring
Over the weekend, our team added resources and optimized the servers that run our billing features. We have been monitoring performance and are seeing material improvement. We will continue to monitor for the next few days before fully closing this issue.

Thank you
The Net Health Team
Posted May 07, 2024 - 12:38 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 30, 2024 - 18:01 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 30, 2024 - 11:25 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 29, 2024 - 19:14 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 29, 2024 - 08:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2024 - 15:38 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 25, 2024 - 18:10 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 25, 2024 - 13:23 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 24, 2024 - 19:55 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 24, 2024 - 15:28 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 24, 2024 - 11:10 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 23, 2024 - 15:26 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 23, 2024 - 08:13 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 22, 2024 - 14:26 EDT
Update
Work continues to be done on the Server and Database side to address the Billing module performance issues, and we are continuing to investigate the issue.
Posted Apr 22, 2024 - 10:24 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 19, 2024 - 13:33 EDT
Update
We are continuing to investigate this issue.
Posted Apr 19, 2024 - 09:40 EDT
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 13:14 EDT
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 08:25 EDT
Update
We are continuing to investigate this issue. We thank you for your patience and apologize for the inconvenience.
Posted Apr 17, 2024 - 07:41 EDT
Update
We are continuing to investigate this issue.
Posted Apr 16, 2024 - 16:09 EDT
Update
We are continuing to investigate this issue.
Posted Apr 16, 2024 - 10:28 EDT
Update
We are continuing to investigate this issue.
Posted Apr 16, 2024 - 08:01 EDT
Investigating
We are aware some clients are experiencing latency within the Billing Module.

We are working as quickly as possible to resolve the issue and appreciate your patience.
Posted Apr 15, 2024 - 12:11 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2024 - 14:18 EDT
Update
We are continuing to investigate this issue.
Posted Apr 12, 2024 - 16:46 EDT
Investigating
We are aware some clients are experiencing latency within the Billing Module. When trying to load information, clients are shown a spinning circle and the information does not appear.
We are working as quickly as possible to resolve the issue and appreciate your patience.

Thank you,
Net Health Team
Posted Apr 11, 2024 - 16:36 EDT
This incident affects: Wound Care (WoundExpert) and Therapy for Hospital & Private Practice (Redoc xFit).