Some Clients experiencing 'Service Unavailable' errors

Incident Report for Net Health StatusPage

Resolved

Net Health Support has not received any additional reports of the issue. This incident is resolved.

Thank you,
Net Health team
Posted Jul 30, 2025 - 09:41 EDT

Identified

We've pinpointed the problem and are presently applying a solution. Users have reported successful logins, and we're actively monitoring the situation.
Posted Jul 28, 2025 - 16:53 EDT

Investigating

Net Health is aware that some users are currently experiencing login errors and display issues within the Care Operating Management (COM) system. A commonly reported error is:

"The requested service, 'https://ORG.Therapy.NetHealth.com/ROX' could not be activated."

Our team is actively investigating the issue and working to resolve it as quickly as possible.
We appreciate your patience and will continue to provide updates as more information becomes available.

Thank you,
The Net Health Team
Posted Jul 28, 2025 - 12:33 EDT
This incident affected: Optima.