Some clients experiencing latency in the Billing Module

Incident Report for Net Health StatusPage

Resolved

This incident is resolved.

Thank you,
Net Health team
Posted Nov 15, 2023 - 09:34 EST

Monitoring

We have applied a fix and restored normal application responsiveness. We will continue to monitor the situation.

Thank you,
Net Health team
Posted Nov 14, 2023 - 09:59 EST

Identified

We have identified the issue and are continuing to work to resolve the problem.

Thank you,
Net Health team
Posted Nov 13, 2023 - 14:39 EST

Investigating

We are aware some clients are experiencing latency when attempting to access the Billing module in both the Net Health Therapy for Hospitals, Private Practice and Net Health Wound Care applications. We have alerted our IT teams and are working to resolve the issue. We apologize for the inconvenience and appreciate your patience.

Thank you,
Net Health team
Posted Nov 13, 2023 - 12:29 EST
This incident affected: WoundExpert and ReDoc.